CVE-2011-4300 Moodle does not properly restrict access to category and course data
Remote attackers can access sensitive category and course data in Moodle by requesting files without proper authorization checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-4300?
CVE-2011-4300 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 11 Jul 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The file_browser component in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 does not properly restrict access to category and course data, which allows remote attackers to obtain potentially sensitive information via a request for a file.
Weakness: CWE-264
Which versions are affected by CVE-2011-4300?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.0.0 | 2.0.5 |
moodle/moodle Packagist | From 2.0.0 | 2.0.5 |
moodle/moodle Packagist | From 2.1 | 2.1.2 |
moodle/moodle Packagist | From 2.1 | 2.1.2 |
Products include Moodle Moodle.
How do I fix CVE-2011-4300?
Upgrade moodle/moodle to a fixed version for your release line: 2.0.5 or 2.1.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2011-4300 being exploited?
There is no known exploitation of CVE-2011-4300 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-9p54-pc88-36c4.