CVE-2011-4301 Moodle Allows Modification of Constants

Medium 5.0 Published Updated

Remote attackers can modify constant form fields in Moodle, allowing submission of unexpected content due to improper handling of Forms API constants.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2011-4301?

CVE-2011-4301 is a medium-severity vulnerability in Moodle Moodle, published on 11 Jul 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant fields.

Which versions are affected by CVE-2011-4301?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions1.9.14
moodle/moodle PackagistAll versions1.9.14
moodle/moodle PackagistFrom 2.02.0.5
moodle/moodle PackagistFrom 2.02.0.5
moodle/moodle PackagistFrom 2.12.1.2
moodle/moodle PackagistFrom 2.12.1.2

Products include Moodle Moodle.

How do I fix CVE-2011-4301?

Upgrade moodle/moodle to a fixed version for your release line: 1.9.14, 2.0.5 or 2.1.2.

Is CVE-2011-4301 being exploited?

There is no known exploitation of CVE-2011-4301 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-jcrj-gmr6-p5j8.

Is CVE-2011-4301 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free