{"answers":{"affected":"6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-4301 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 1.9.14, 2.0.5 or 2.1.2.","what":"CVE-2011-4301 is a medium-severity vulnerability in Moodle Moodle, published on 11 Jul 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-4301 and fix it if it is affected.\n\nWhat it is: CVE-2011-4301 is a medium-severity vulnerability in Moodle Moodle, published on 11 Jul 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2011-4301 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions; fixed in 1.9.14\n- moodle/moodle (Packagist): affected all versions; fixed in 1.9.14\n- moodle/moodle (Packagist): affected from 2.0; fixed in 2.0.5\n- moodle/moodle (Packagist): affected from 2.0; fixed in 2.0.5\n- moodle/moodle (Packagist): affected from 2.1; fixed in 2.1.2\n- moodle/moodle (Packagist): affected from 2.1; fixed in 2.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-4301/ (Markdown: https://insights.sbomify.com/CVE-2011-4301/index.md)","id":"CVE-2011-4301","markdown":"https://insights.sbomify.com/CVE-2011-4301/index.md","name":"CVE-2011-4301","record":{"aliases":["GHSA-jcrj-gmr6-p5j8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Remote attackers can modify constant form fields in Moodle, allowing submission of unexpected content due to improper handling of Forms API constants.","user_interaction":"required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[],"description":"The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant fields.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle Allows Modification of Constants","id":"CVE-2011-4301","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"business_logic","year":"2011"},"n_packages":6,"n_references":3,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2011-4302"},"packages":[{"ecosystem":"Packagist","fixed":["1.9.14"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-jcrj-gmr6-p5j8"},{"ecosystem":"Packagist","fixed":["1.9.14"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-jcrj-gmr6-p5j8"},{"ecosystem":"Packagist","fixed":["2.0.5"],"introduced":["2.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-jcrj-gmr6-p5j8"},{"ecosystem":"Packagist","fixed":["2.0.5"],"introduced":["2.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-jcrj-gmr6-p5j8"},{"ecosystem":"Packagist","fixed":["2.1.2"],"introduced":["2.1"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-jcrj-gmr6-p5j8"},{"ecosystem":"Packagist","fixed":["2.1.2"],"introduced":["2.1"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-jcrj-gmr6-p5j8"}],"prev":{"headline":"Moodle does not properly restrict access to category and course data","id":"CVE-2011-4300"},"products":["n/a"],"published":"2012-07-11","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can modify constant form fields in Moodle, allowing submission of unexpected content due to improper handling of Forms API constants.","url":"https://insights.sbomify.com/CVE-2011-4301/"}