CVE-2011-4343 Apache MyFaces Vulnerable to EL Injection
Remote attackers can inject EL expressions in Apache MyFaces Core, leading to code execution and information disclosure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-4343?
CVE-2011-4343 is a high-severity code injection vulnerability in n/a, published on 8 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Information disclosure vulnerability in Apache MyFaces Core 2.0.1 through 2.0.10 and 2.1.0 through 2.1.4 allows remote attackers to inject EL expressions via crafted parameters.
Weakness: CWE-200
Which versions are affected by CVE-2011-4343?
4 open source packages ship an affected version, including org.apache.myfaces.core:myfaces-core-module. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.myfaces.core:myfaces-core-module Maven | From 2.0.1 | 2.0.11 |
org.apache.myfaces.core:myfaces-core-module Maven | From 2.0.1 | 2.0.11 |
org.apache.myfaces.core:myfaces-core-module Maven | From 2.1.0 | 2.1.5 |
org.apache.myfaces.core:myfaces-core-module Maven | From 2.1.0 | 2.1.5 |
Products include Apache Myfaces.
How do I fix CVE-2011-4343?
Upgrade org.apache.myfaces.core:myfaces-core-module to a fixed version for your release line: 2.0.11 or 2.1.5.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2011-4343 being exploited?
There is no known exploitation of CVE-2011-4343 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as CVE-2011-4359, GHSA-jq6g-p65r-44xr.