CVE-2011-4344 Jenkins allows Cross-Site Scripting (XSS)

Low 2.6 Published Updated

Remote attackers can inject arbitrary web script or HTML via error messages in Jenkins when using a stand-alone container.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2011-4344?

CVE-2011-4344 is a low-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 1 Dec 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in Jenkins Core in Jenkins before 1.438, and 1.409 LTS before 1.409.3 LTS, when a stand-alone container is used, allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Weakness: CWE-79

Which versions are affected by CVE-2011-4344?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.409.3
org.jenkins-ci.main:jenkins-core MavenAll versions1.409.3
org.jenkins-ci.main:jenkins-core MavenFrom 1.4101.438
org.jenkins-ci.main:jenkins-core MavenFrom 1.4101.438

Products include Jenkins Jenkins.

How do I fix CVE-2011-4344?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.409.3 or 1.438.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2011-4344 being exploited?

There is no known exploitation of CVE-2011-4344 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-q3rp-555r-hh6r.

Is CVE-2011-4344 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free