CVE-2011-4356 Celery local privilege escalation vulnerability
Local attackers can escalate privileges by exploiting improper UID/GID handling in Celery worker processes during task execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-4356?
CVE-2011-4356 is a medium-severity vulnerability in n/a, published on 5 Dec 2011. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of the --uid and --gid arguments to celerybeat, celeryd_detach, celeryd-multi, and celeryev, which allows local users to gain privileges via vectors involving crafted code that is executed by the worker process.
Weakness: CWE-264
Which versions are affected by CVE-2011-4356?
7 open source packages ship an affected version, including celery. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
celery PyPI | From 2.1 | 2.2.8, 2.3.4, 2.4.4 |
celery PyPI | From 2.1.0 | 2.2.8 |
celery PyPI | From 2.1.0 | 2.2.8 |
celery PyPI | From 2.3.0 | 2.3.4 |
celery PyPI | From 2.3.0 | 2.3.4 |
celery PyPI | From 2.4.0 | 2.4.4 |
1 more packages
celery PyPI | From 2.4.0 | 2.4.4 |
Products include Celeryproject Celery.
How do I fix CVE-2011-4356?
Upgrade celery to a fixed version for your release line: 2.2.8, 2.3.4 or 2.4.4.
Is CVE-2011-4356 being exploited?
There is no known exploitation of CVE-2011-4356 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2011-4356, GHSA-rpc6-h455-3rx5, PYSEC-2011-17.