{"answers":{"affected":"7 open source packages ship an affected version, including celery. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-4356 in the wild and no public exploit code.","fix":"Upgrade celery to a fixed version for your release line: 2.2.8, 2.3.4 or 2.4.4.","what":"CVE-2011-4356 is a medium-severity vulnerability in n/a, published on 5 Dec 2011. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2011-4356 and fix it if it is affected.\n\nWhat it is: CVE-2011-4356 is a medium-severity vulnerability in n/a, published on 5 Dec 2011. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2011-4356 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- celery (PyPI): affected from 2.1; fixed in 2.2.8, 2.3.4, 2.4.4\n- celery (PyPI): affected from 2.1.0; fixed in 2.2.8\n- celery (PyPI): affected from 2.1.0; fixed in 2.2.8\n- celery (PyPI): affected from 2.3.0; fixed in 2.3.4\n- celery (PyPI): affected from 2.3.0; fixed in 2.3.4\n- celery (PyPI): affected from 2.4.0; fixed in 2.4.4\n- celery (PyPI): affected from 2.4.0; fixed in 2.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-4356/ (Markdown: https://insights.sbomify.com/CVE-2011-4356/index.md)","id":"CVE-2011-4356","markdown":"https://insights.sbomify.com/CVE-2011-4356/index.md","name":"CVE-2011-4356","record":{"aliases":["DEBIAN-CVE-2011-4356","GHSA-rpc6-h455-3rx5","PYSEC-2011-17"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Celery task queue","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges by exploiting improper UID/GID handling in Celery worker processes during task execution.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"celery","vendor":"celeryproject"}],"cvss":{"score":6.9,"severity":"medium","source":"nvd","vector":"AV:L/AC:M/Au:N/C:C/I:C/A:C","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of the --uid and --gid arguments to celerybeat, celeryd_detach, celeryd-multi, and celeryev, which allows local users to gain privileges via vectors involving crafted code that is executed by the worker process.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Celery local privilege escalation vulnerability","id":"CVE-2011-4356","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2011"},"n_packages":7,"n_references":4,"next":{"headline":"Other in n/a","id":"CVE-2011-4357"},"packages":[{"ecosystem":"PyPI","fixed":["2.2.8","2.3.4","2.4.4"],"introduced":["2.1","2.3","2.4"],"last_affected":[],"package":"celery","purl":"pkg:pypi/celery","source":"PYSEC-2011-17"},{"ecosystem":"PyPI","fixed":["2.2.8"],"introduced":["2.1.0"],"last_affected":[],"package":"celery","purl":null,"source":"GHSA-rpc6-h455-3rx5"},{"ecosystem":"PyPI","fixed":["2.2.8"],"introduced":["2.1.0"],"last_affected":[],"package":"celery","purl":"pkg:pypi/celery","source":"GHSA-rpc6-h455-3rx5"},{"ecosystem":"PyPI","fixed":["2.3.4"],"introduced":["2.3.0"],"last_affected":[],"package":"celery","purl":null,"source":"GHSA-rpc6-h455-3rx5"},{"ecosystem":"PyPI","fixed":["2.3.4"],"introduced":["2.3.0"],"last_affected":[],"package":"celery","purl":"pkg:pypi/celery","source":"GHSA-rpc6-h455-3rx5"},{"ecosystem":"PyPI","fixed":["2.4.4"],"introduced":["2.4.0"],"last_affected":[],"package":"celery","purl":null,"source":"GHSA-rpc6-h455-3rx5"},{"ecosystem":"PyPI","fixed":["2.4.4"],"introduced":["2.4.0"],"last_affected":[],"package":"celery","purl":"pkg:pypi/celery","source":"GHSA-rpc6-h455-3rx5"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2011-4355"},"products":["n/a"],"published":"2011-12-05","related":[{"cvss_score":7.5,"headline":"Stored Command Injection","id":"CVE-2021-23727","kev_date_added":null,"published":"2021-12-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Local attackers can escalate privileges by exploiting improper UID/GID handling in Celery worker processes during task execution.","url":"https://insights.sbomify.com/CVE-2011-4356/"}