# CVE-2011-4356: Celery local privilege escalation vulnerability

> Local attackers can escalate privileges by exploiting improper UID/GID handling in Celery worker processes during task execution.

- **Severity:** Medium 6.9 (`AV:L/AC:M/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2011
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2011-4356, GHSA-rpc6-h455-3rx5, PYSEC-2011-17

## What is CVE-2011-4356?

CVE-2011-4356 is a medium-severity vulnerability in n/a, published on 5 Dec 2011. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of the --uid and --gid arguments to celerybeat, celeryd_detach, celeryd-multi, and celeryev, which allows local users to gain privileges via vectors involving crafted code that is executed by the worker process.

Weakness: CWE-264

## Which versions are affected by CVE-2011-4356?

7 open source packages ship an affected version, including celery. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `celery` | PyPI | From 2.1 | 2.2.8, 2.3.4, 2.4.4 |
| `celery` | PyPI | From 2.1.0 | 2.2.8 |
| `celery` | PyPI | From 2.1.0 | 2.2.8 |
| `celery` | PyPI | From 2.3.0 | 2.3.4 |
| `celery` | PyPI | From 2.3.0 | 2.3.4 |
| `celery` | PyPI | From 2.4.0 | 2.4.4 |
| `celery` | PyPI | From 2.4.0 | 2.4.4 |

Products: Celeryproject Celery.

## How do I fix CVE-2011-4356?

Upgrade celery to a fixed version for your release line: 2.2.8, 2.3.4 or 2.4.4.

## Is CVE-2011-4356 being exploited?

There is no known exploitation of CVE-2011-4356 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-23727](https://insights.sbomify.com/CVE-2021-23727/): Stored Command Injection (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4356 and fix it if it is affected.

What it is: CVE-2011-4356 is a medium-severity vulnerability in n/a, published on 5 Dec 2011. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-4356 in the wild and no public exploit code.

Affected packages and fixed versions:
- celery (PyPI): affected from 2.1; fixed in 2.2.8, 2.3.4, 2.4.4
- celery (PyPI): affected from 2.1.0; fixed in 2.2.8
- celery (PyPI): affected from 2.1.0; fixed in 2.2.8
- celery (PyPI): affected from 2.3.0; fixed in 2.3.4
- celery (PyPI): affected from 2.3.0; fixed in 2.3.4
- celery (PyPI): affected from 2.4.0; fixed in 2.4.4
- celery (PyPI): affected from 2.4.0; fixed in 2.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4356/ (Markdown: https://insights.sbomify.com/CVE-2011-4356/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4356
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4356
- OSV: https://osv.dev/vulnerability/CVE-2011-4356

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4356/
Summaries are generated and may contain mistakes; the official description above is the record.
