# CVE-2011-4367: Apache MyFaces Vulnerable to Path Traversal

> Remote attackers can read arbitrary files via directory traversal in Apache MyFaces JSF resource handling, exposing sensitive data.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2014
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-gjfx-9wx3-j6r7

## What is CVE-2011-4367?

CVE-2011-4367 is a medium-severity path traversal vulnerability in n/a, published on 19 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple directory traversal vulnerabilities in MyFaces JavaServer Faces (JSF) in Apache MyFaces Core 2.0.x before 2.0.12 and 2.1.x before 2.1.6 allow remote attackers to read arbitrary files via a .. (dot dot) in the (1) ln parameter to faces/javax.faces.resource/web.xml or (2) the PATH_INFO to faces/javax.faces.resource/.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2011-4367?

4 open source packages ship an affected version, including org.apache.myfaces.core:myfaces-impl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.myfaces.core:myfaces-impl` | Maven | From 2.0.0 | 2.0.12 |
| `org.apache.myfaces.core:myfaces-impl` | Maven | From 2.0.0 | 2.0.12 |
| `org.apache.myfaces.core:myfaces-impl` | Maven | From 2.1.0 | 2.1.6 |
| `org.apache.myfaces.core:myfaces-impl` | Maven | From 2.1.0 | 2.1.6 |

Products: Apache Myfaces.

## How do I fix CVE-2011-4367?

Upgrade org.apache.myfaces.core:myfaces-impl to a fixed version for your release line: 2.0.12 or 2.1.6.

## Is CVE-2011-4367 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-4367 exists.

Public exploit code:

- Apache MyFaces - 'ln' Information Disclosure (exploitdb)
- https://github.com/shoucheng3/apache__myfaces_CVE-2011-4367_2-0-11 (github_poc): https://github.com/shoucheng3/apache__myfaces_CVE-2011-4367_2-0-11

## Other vulnerabilities in n/a

- [CVE-2021-26296](https://insights.sbomify.com/CVE-2021-26296/): Cross-Site Request Forgery (CSRF) vulnerability in Apache MyFaces (high 7.5)
- [CVE-2011-4343](https://insights.sbomify.com/CVE-2011-4343/): Apache MyFaces Vulnerable to EL Injection (high 7.5)
- [CVE-2010-2057](https://insights.sbomify.com/CVE-2010-2057/): Improper Authentication in Apache MyFaces (medium 5.0)
- [CVE-2010-2086](https://insights.sbomify.com/CVE-2010-2086/): Apache MyFaces Cross-site Scripting vulnerability (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4367 and fix it if it is affected.

What it is: CVE-2011-4367 is a medium-severity path traversal vulnerability in n/a, published on 19 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-4367 exists.

Affected packages and fixed versions:
- org.apache.myfaces.core:myfaces-impl (Maven): affected from 2.0.0; fixed in 2.0.12
- org.apache.myfaces.core:myfaces-impl (Maven): affected from 2.0.0; fixed in 2.0.12
- org.apache.myfaces.core:myfaces-impl (Maven): affected from 2.1.0; fixed in 2.1.6
- org.apache.myfaces.core:myfaces-impl (Maven): affected from 2.1.0; fixed in 2.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4367/ (Markdown: https://insights.sbomify.com/CVE-2011-4367/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4367
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4367
- OSV: https://osv.dev/vulnerability/CVE-2011-4367

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4367/
Summaries are generated and may contain mistakes; the official description above is the record.
