CVE-2011-4628 Typo3 Authentication Bypass

Critical 9.8 Published Updated

Remote attackers can bypass backend authentication in TYPO3 CMS via crafted requests, requiring administrators to upgrade to secure versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2011-4628?

CVE-2011-4628 is a critical authentication bypass vulnerability in Typo3 Typo3, published on 6 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to bypass authentication mechanisms in the backend through a crafted request.

Weakness: CWE-287

Which versions are affected by CVE-2011-4628?

6 open source packages ship an affected version, including typo3/cms. It affects 1 product.

PackageAffectedFixed in
typo3/cms PackagistAll versions4.3.12
typo3/cms PackagistAll versions4.3.12
typo3/cms PackagistFrom 4.4.04.4.9
typo3/cms PackagistFrom 4.4.04.4.9
typo3/cms PackagistFrom 4.5.04.5.4
typo3/cms PackagistFrom 4.5.04.5.4

Products include Typo3 Typo3.

How do I fix CVE-2011-4628?

Upgrade typo3/cms to a fixed version for your release line: 4.3.12, 4.4.9 or 4.5.4.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2011-4628 being exploited?

There is no known exploitation of CVE-2011-4628 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-79gv-5cgx-x6rx.

Is CVE-2011-4628 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free