# CVE-2011-4628: Typo3 Authentication Bypass

> Remote attackers can bypass backend authentication in TYPO3 CMS via crafted requests, requiring administrators to upgrade to secure versions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2019
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-79gv-5cgx-x6rx

## What is CVE-2011-4628?

CVE-2011-4628 is a critical authentication bypass vulnerability in Typo3 Typo3, published on 6 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to bypass authentication mechanisms in the backend through a crafted request.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2011-4628?

6 open source packages ship an affected version, including typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | All versions | 4.3.12 |
| `typo3/cms` | Packagist | All versions | 4.3.12 |
| `typo3/cms` | Packagist | From 4.4.0 | 4.4.9 |
| `typo3/cms` | Packagist | From 4.4.0 | 4.4.9 |
| `typo3/cms` | Packagist | From 4.5.0 | 4.5.4 |
| `typo3/cms` | Packagist | From 4.5.0 | 4.5.4 |

Products: Typo3 Typo3.

## How do I fix CVE-2011-4628?

Upgrade typo3/cms to a fixed version for your release line: 4.3.12, 4.4.9 or 4.5.4.

## Is CVE-2011-4628 being exploited?

There is no known exploitation of CVE-2011-4628 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)
- [CVE-2020-15098](https://insights.sbomify.com/CVE-2020-15098/): Missing Required Cryptographic Step Leading to Sensitive Information Disclosure in TYPO3 CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4628 and fix it if it is affected.

What it is: CVE-2011-4628 is a critical authentication bypass vulnerability in Typo3 Typo3, published on 6 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-4628 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected all versions; fixed in 4.3.12
- typo3/cms (Packagist): affected all versions; fixed in 4.3.12
- typo3/cms (Packagist): affected from 4.4.0; fixed in 4.4.9
- typo3/cms (Packagist): affected from 4.4.0; fixed in 4.4.9
- typo3/cms (Packagist): affected from 4.5.0; fixed in 4.5.4
- typo3/cms (Packagist): affected from 4.5.0; fixed in 4.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4628/ (Markdown: https://insights.sbomify.com/CVE-2011-4628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4628
- OSV: https://osv.dev/vulnerability/CVE-2011-4628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4628/
Summaries are generated and may contain mistakes; the official description above is the record.
