CVE-2011-4630 Typo3 XSS Vulnerability

Medium 5.4 Published Updated

Remote attackers can inject arbitrary web script or HTML via the browse_links wizard in TYPO3, potentially leading to session hijacking or malicious actions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2011-4630?

CVE-2011-4630 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 6 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Cross-site Scripting (XSS) in TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to inject arbitrary web script or HTML via the browse_links wizard.

Weakness: CWE-79

Which versions are affected by CVE-2011-4630?

6 open source packages ship an affected version, including typo3/cms. It affects 1 product.

PackageAffectedFixed in
typo3/cms PackagistAll versions4.3.12
typo3/cms PackagistAll versions4.3.12
typo3/cms PackagistFrom 4.4.04.4.9
typo3/cms PackagistFrom 4.4.04.4.9
typo3/cms PackagistFrom 4.5.04.5.4
typo3/cms PackagistFrom 4.5.04.5.4

Products include Typo3 Typo3.

How do I fix CVE-2011-4630?

Upgrade typo3/cms to a fixed version for your release line: 4.3.12, 4.4.9 or 4.5.4.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2011-4630 being exploited?

There is no known exploitation of CVE-2011-4630 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-29wr-24h5-95r5.

Is CVE-2011-4630 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free