# CVE-2011-4634: phpMyAdmin vulnerable to Cross-site Scripting

> Remote attackers can inject arbitrary web script or HTML via crafted database names or SQL queries in phpMyAdmin, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Dec 2011
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2011-4634, GHSA-9j9h-cpgc-8356

## What is CVE-2011-4634?

CVE-2011-4634 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 22 Dec 2011. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.8 allow remote attackers to inject arbitrary web script or HTML via (1) a crafted database name, related to the Database Synchronize panel; (2) a crafted database name, related to the Database rename panel; (3) a crafted SQL query, related to the table overview panel; (4) a crafted SQL query, related to the view creation dialog; (5) a crafted column type, related to the table search dialog; or (6) a crafted column type, related to the create index dialog.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2011-4634?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.4.0 | 3.4.8 |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.4.0 | 3.4.8 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2011-4634?

Upgrade phpmyadmin/phpmyadmin to 3.4.8 or later.

## Is CVE-2011-4634 being exploited?

There is no known exploitation of CVE-2011-4634 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4634 and fix it if it is affected.

What it is: CVE-2011-4634 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 22 Dec 2011. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2011-4634 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 3.4.0; fixed in 3.4.8
- phpmyadmin/phpmyadmin (Packagist): affected from 3.4.0; fixed in 3.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4634/ (Markdown: https://insights.sbomify.com/CVE-2011-4634/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4634
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4634
- OSV: https://osv.dev/vulnerability/CVE-2011-4634

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4634/
Summaries are generated and may contain mistakes; the official description above is the record.
