CVE-2011-4858 Improper Input Validation in Apache Tomcat
Remote attackers can cause denial of service via CPU exhaustion by sending crafted form parameters that trigger hash collisions in Apache Tomcat.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-4858?
CVE-2011-4858 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 5 Jan 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Tomcat before 5.5.35, 6.x before 6.0.35, and 7.x before 7.0.23 computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters.
Weakness: CWE-399
Which versions are affected by CVE-2011-4858?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.35 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.35 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.35 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.35 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.23 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.23 |
Products include Apache Tomcat.
How do I fix CVE-2011-4858?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.35, 6.0.35 or 7.0.23.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2011-4858 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-4858 exists.
Public exploit code: 1 Metasploit module and 1 Exploit-DB entry.
Other vulnerabilities in Apache Tomcat
Sources
Also known as CVE-2011-4084, GHSA-wr3m-gw98-mc3j.