# CVE-2011-4858: Improper Input Validation in Apache Tomcat

> Remote attackers can cause denial of service via CPU exhaustion by sending crafted form parameters that trigger hash collisions in Apache Tomcat.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2012
- **Updated:** 7 Aug 2024
- **Also known as:** CVE-2011-4084, GHSA-wr3m-gw98-mc3j

## What is CVE-2011-4858?

CVE-2011-4858 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 5 Jan 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Tomcat before 5.5.35, 6.x before 6.0.35, and 7.x before 7.0.23 computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters.

Weakness: CWE-399

## Which versions are affected by CVE-2011-4858?

6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.35 |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.35 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.35 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.35 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.23 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.23 |

Products: Apache Tomcat.

## How do I fix CVE-2011-4858?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.35, 6.0.35 or 7.0.23.

## Is CVE-2011-4858 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-4858 exists.

Public exploit code:

- MyBulletinBoard (MyBB) 1.1.5 - 'CLIENT-IP' SQL Injection (exploitdb)
- Hashtable Collisions (metasploit)

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4858 and fix it if it is affected.

What it is: CVE-2011-4858 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 5 Jan 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-4858 exists.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.35
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.35
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.35
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.35
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.23
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4858/ (Markdown: https://insights.sbomify.com/CVE-2011-4858/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4858
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4858
- OSV: https://osv.dev/vulnerability/CVE-2011-4858

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4858/
Summaries are generated and may contain mistakes; the official description above is the record.
