# CVE-2011-4900: Typo3 Information Disclosure

> An attacker can access sensitive information in the TYPO3 backend, potentially exposing confidential data to unauthorized users.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2019
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-rwx5-7x5r-jgrm

## What is CVE-2011-4900?

CVE-2011-4900 is a medium-severity vulnerability in Debian Debian Linux, published on 6 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

TYPO3 before 4.5.4 allows Information Disclosure in the backend.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2011-4900?

2 open source packages ship an affected version, including typo3/cms. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | All versions | 4.5.4 |
| `typo3/cms` | Packagist | All versions | 4.5.4 |

Products: Debian Debian Linux, Typo3 Typo3.

## How do I fix CVE-2011-4900?

Upgrade typo3/cms to 4.5.4 or later.

## Is CVE-2011-4900 being exploited?

There is no known exploitation of CVE-2011-4900 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4900 and fix it if it is affected.

What it is: CVE-2011-4900 is a medium-severity vulnerability in Debian Debian Linux, published on 6 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-4900 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected all versions; fixed in 4.5.4
- typo3/cms (Packagist): affected all versions; fixed in 4.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4900/ (Markdown: https://insights.sbomify.com/CVE-2011-4900/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4900
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4900
- OSV: https://osv.dev/vulnerability/CVE-2011-4900

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4900/
Summaries are generated and may contain mistakes; the official description above is the record.
