CVE-2011-4901 Typo3 Arbitrary Information Disclosure
Remote attackers can extract arbitrary information from the TYPO3 database, requiring administrators to upgrade the CMS.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-4901?
CVE-2011-4901 is a medium-severity vulnerability in Typo3 Typo3, published on 6 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to extract arbitrary information from the TYPO3 database.
Weakness: CWE-200
Which versions are affected by CVE-2011-4901?
6 open source packages ship an affected version, including typo3/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms Packagist | All versions | 4.3.12 |
typo3/cms Packagist | All versions | 4.3.12 |
typo3/cms Packagist | From 4.4.0 | 4.4.9 |
typo3/cms Packagist | From 4.4.0 | 4.4.9 |
typo3/cms Packagist | From 4.5.0 | 4.5.4 |
typo3/cms Packagist | From 4.5.0 | 4.5.4 |
Products include Typo3 Typo3.
How do I fix CVE-2011-4901?
Upgrade typo3/cms to a fixed version for your release line: 4.3.12, 4.4.9 or 4.5.4.
Is CVE-2011-4901 being exploited?
There is no known exploitation of CVE-2011-4901 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as GHSA-8grp-3j5v-543g.