CVE-2011-4924 Zope XSS Vulnerability
Remote attackers can inject arbitrary web script or HTML via unsanitized error messages in Zope, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2011-4924?
CVE-2011-4924 is a medium-severity cross-site scripting vulnerability in zope2, zope3, published on 25 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104
Weakness: CWE-79
Which versions are affected by CVE-2011-4924?
8 open source packages ship an affected version, including zope2 and zope. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
zope2 PyPI | All versions | 2.12.22, 2.13.12 |
zope2 PyPI | All versions | 2.12.22 |
zope2 PyPI | All versions | 2.12.22 |
zope2 PyPI | From 2.13.0a1 | 2.13.12 |
zope2 PyPI | From 2.13.0a1 | 2.13.12 |
zope PyPI | From 3.1.1 | 3.7.3 |
2 more packages
zope PyPI | From 3.1.1 | 3.7.3 |
zope PyPI | From 3.1.1 | 3.7.3 |
Products include Zope Zope.
How do I fix CVE-2011-4924?
Upgrade zope2 to a fixed version for your release line: 2.12.22 or 2.13.12.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2011-4924 being exploited?
There is no known exploitation of CVE-2011-4924 in the wild and no public exploit code.
Other vulnerabilities in zope2, zope3
- CVE-2000-0062 Zope DTML implementation Improper Authentication
- CVE-2021-32674 Remote Code Execution via traversal in TAL expressions
- CVE-2000-1211 Zope does not properly perform security registration for legacy names
- CVE-2002-0170 Zope does not properly verify the access for objects with proxy roles
- CVE-2002-0688 ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions
Sources
Also known as GHSA-vh6g-786f-hxxp, PYSEC-2026-3440, PYSEC-2026-766.