{"answers":{"affected":"8 open source packages ship an affected version, including zope2 and zope. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-4924 in the wild and no public exploit code.","fix":"Upgrade zope2 to a fixed version for your release line: 2.12.22 or 2.13.12.","what":"CVE-2011-4924 is a medium-severity cross-site scripting vulnerability in zope2, zope3, published on 25 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-4924 and fix it if it is affected.\n\nWhat it is: CVE-2011-4924 is a medium-severity cross-site scripting vulnerability in zope2, zope3, published on 25 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2011-4924 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zope2 (PyPI): affected all versions; fixed in 2.12.22, 2.13.12\n- zope2 (PyPI): affected all versions; fixed in 2.12.22\n- zope2 (PyPI): affected all versions; fixed in 2.12.22\n- zope2 (PyPI): affected from 2.13.0a1; fixed in 2.13.12\n- zope2 (PyPI): affected from 2.13.0a1; fixed in 2.13.12\n- zope (PyPI): affected from 3.1.1; fixed in 3.7.3\n- zope (PyPI): affected from 3.1.1; fixed in 3.7.3\n- zope (PyPI): affected from 3.1.1; fixed in 3.7.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-4924/ (Markdown: https://insights.sbomify.com/CVE-2011-4924/index.md)","id":"CVE-2011-4924","markdown":"https://insights.sbomify.com/CVE-2011-4924/index.md","name":"CVE-2011-4924","record":{"aliases":["GHSA-vh6g-786f-hxxp","PYSEC-2026-3440","PYSEC-2026-766"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Zope web application server","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via unsanitized error messages in Zope, potentially leading to code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"zope","vendor":"zope"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Zope XSS Vulnerability","id":"CVE-2011-4924","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2011"},"n_packages":8,"n_references":7,"next":{"headline":"Auth bypass in n/a","id":"CVE-2011-4925"},"packages":[{"ecosystem":"PyPI","fixed":["3.7.3"],"introduced":["3.1.1"],"last_affected":[],"package":"zope","purl":null,"source":"GHSA-vh6g-786f-hxxp"},{"ecosystem":"PyPI","fixed":["3.7.3"],"introduced":["3.1.1"],"last_affected":[],"package":"zope","purl":"pkg:pypi/zope","source":"GHSA-vh6g-786f-hxxp"},{"ecosystem":"PyPI","fixed":["3.7.3"],"introduced":["3.1.1"],"last_affected":[],"package":"zope","purl":"pkg:pypi/zope","source":"PYSEC-2026-3440"},{"ecosystem":"PyPI","fixed":["2.12.22","2.13.12"],"introduced":["0","2.13.0a1"],"last_affected":[],"package":"zope2","purl":"pkg:pypi/zope2","source":"PYSEC-2026-766"},{"ecosystem":"PyPI","fixed":["2.12.22"],"introduced":["0"],"last_affected":[],"package":"zope2","purl":null,"source":"GHSA-vh6g-786f-hxxp"},{"ecosystem":"PyPI","fixed":["2.12.22"],"introduced":["0"],"last_affected":[],"package":"zope2","purl":"pkg:pypi/zope2","source":"GHSA-vh6g-786f-hxxp"},{"ecosystem":"PyPI","fixed":["2.13.12"],"introduced":["2.13.0a1"],"last_affected":[],"package":"zope2","purl":null,"source":"GHSA-vh6g-786f-hxxp"},{"ecosystem":"PyPI","fixed":["2.13.12"],"introduced":["2.13.0a1"],"last_affected":[],"package":"zope2","purl":"pkg:pypi/zope2","source":"GHSA-vh6g-786f-hxxp"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2011-4923"},"products":["zope2, zope3"],"published":"2019-11-25","related":[{"cvss_score":10,"headline":"Zope DTML implementation Improper Authentication","id":"CVE-2000-0062","kev_date_added":null,"published":"2000-04-18"},{"cvss_score":8.8,"headline":"Remote Code Execution via traversal in TAL expressions","id":"CVE-2021-32674","kev_date_added":null,"published":"2021-06-08"},{"cvss_score":7.5,"headline":"Zope does not properly perform security registration for legacy names","id":"CVE-2000-1211","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"Zope does not properly verify the access for objects with proxy roles","id":"CVE-2002-0170","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions","id":"CVE-2002-0688","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2001-1227","kev_date_added":null,"published":"2002-06-25"},{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2001-1278","kev_date_added":null,"published":"2002-05-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["zope"]},"summary":"Remote attackers can inject arbitrary web script or HTML via unsanitized error messages in Zope, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2011-4924/"}