# CVE-2011-4932: ImpressPages CMS eval injection vulnerability

> Remote attackers can execute arbitrary code via eval injection in the content management module of ImpressPages CMS.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2012
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-fr34-mx6j-vpxh

## What is CVE-2011-4932?

CVE-2011-4932 is a high-severity code injection vulnerability in n/a, published on 6 Oct 2012. It can be exploited over the network, with no action from the victim.

### Official description

Eval injection vulnerability in ip_cms/modules/standard/content_management/actions.php in ImpressPages CMS 1.0.12 and possibly other versons before 1.0.13 allows remote attackers to execute arbitrary code via the cm_group parameter.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2011-4932?

2 open source packages ship an affected version, including impresspages/impresspages. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `impresspages/impresspages` | Packagist | All versions | 1.0.13 |
| `impresspages/impresspages` | Packagist | All versions | 1.0.13 |

Products: Impresspages Impresspages Cms.

## How do I fix CVE-2011-4932?

Upgrade impresspages/impresspages to 1.0.13 or later.

## Is CVE-2011-4932 being exploited?

There is no known exploitation of CVE-2011-4932 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2011-4943](https://insights.sbomify.com/CVE-2011-4943/): ImpressPages CMS RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4932 and fix it if it is affected.

What it is: CVE-2011-4932 is a high-severity code injection vulnerability in n/a, published on 6 Oct 2012. It can be exploited over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-4932 in the wild and no public exploit code.

Affected packages and fixed versions:
- impresspages/impresspages (Packagist): affected all versions; fixed in 1.0.13
- impresspages/impresspages (Packagist): affected all versions; fixed in 1.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4932/ (Markdown: https://insights.sbomify.com/CVE-2011-4932/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4932
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4932
- OSV: https://osv.dev/vulnerability/CVE-2011-4932

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4932/
Summaries are generated and may contain mistakes; the official description above is the record.
