# CVE-2011-4941: Piwik (now Matomo) Vulnerable to Arbitrary Code Execution

> Remote attackers with view permissions can execute arbitrary code in Piwik analytics software.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2012
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-2qr8-h6pq-m27v

## What is CVE-2011-4941?

CVE-2011-4941 is a medium-severity code injection vulnerability in n/a, published on 18 Sep 2012. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Unspecified vulnerability in Piwik 1.2 through 1.4 allows remote attackers with the view permission to execute arbitrary code via unknown attack vectors.

## Which versions are affected by CVE-2011-4941?

4 open source packages ship an affected version, including matomo/matomo and piwik/piwik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matomo/matomo` | Packagist | From 1.2 | 1.5 |
| `matomo/matomo` | Packagist | From 1.2 | 1.5 |
| `piwik/piwik` | Packagist | From 1.2 | 1.5 |
| `piwik/piwik` | Packagist | From 1.2 | 1.5 |

Products: Matomo Matomo.

## How do I fix CVE-2011-4941?

Upgrade matomo/matomo to 1.5 or later.

## Is CVE-2011-4941 being exploited?

There is no known exploitation of CVE-2011-4941 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-7815](https://insights.sbomify.com/CVE-2015-7815/): Path traversal in n/a (high 7.5)
- [CVE-2015-7816](https://insights.sbomify.com/CVE-2015-7816/): Deserialization in n/a (high 7.5)
- [CVE-2009-4137](https://insights.sbomify.com/CVE-2009-4137/): Deserialization in n/a (high 7.5)
- [CVE-2009-4140](https://insights.sbomify.com/CVE-2009-4140/): File upload in n/a (high 7.5)
- [CVE-2010-2786](https://insights.sbomify.com/CVE-2010-2786/): Path traversal in n/a (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4941 and fix it if it is affected.

What it is: CVE-2011-4941 is a medium-severity code injection vulnerability in n/a, published on 18 Sep 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-4941 in the wild and no public exploit code.

Affected packages and fixed versions:
- matomo/matomo (Packagist): affected from 1.2; fixed in 1.5
- matomo/matomo (Packagist): affected from 1.2; fixed in 1.5
- piwik/piwik (Packagist): affected from 1.2; fixed in 1.5
- piwik/piwik (Packagist): affected from 1.2; fixed in 1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4941/ (Markdown: https://insights.sbomify.com/CVE-2011-4941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4941
- OSV: https://osv.dev/vulnerability/CVE-2011-4941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4941/
Summaries are generated and may contain mistakes; the official description above is the record.
