CVE-2011-4943 ImpressPages CMS RCE

Critical 9.8 Published Updated

Remote attackers can execute arbitrary code on ImpressPages CMS installations, requiring an upgrade to the latest version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2011-4943?

CVE-2011-4943 is a critical code injection vulnerability in ImpressPages CMS, published on 22 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

ImpressPages CMS v1.0.12 has Unspecified Remote Code Execution (fixed in v1.0.13)

Which versions are affected by CVE-2011-4943?

2 open source packages ship an affected version, including impresspages/impresspages. It affects 1 product.

PackageAffectedFixed in
impresspages/impresspages PackagistAll versions1.0.13
impresspages/impresspages PackagistAll versions1.0.13

Products include Impresspages Impresspages Cms.

How do I fix CVE-2011-4943?

Upgrade impresspages/impresspages to 1.0.13 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2011-4943 being exploited?

There is no known exploitation of CVE-2011-4943 in the wild and no public exploit code.

Sources

Also known as GHSA-4xf9-4r44-86rc.

Is CVE-2011-4943 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free