{"answers":{"affected":"2 open source packages ship an affected version, including impresspages/impresspages. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-4943 in the wild and no public exploit code.","fix":"Upgrade impresspages/impresspages to 1.0.13 or later.","what":"CVE-2011-4943 is a critical code injection vulnerability in ImpressPages CMS, published on 22 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2011-4943 and fix it if it is affected.\n\nWhat it is: CVE-2011-4943 is a critical code injection vulnerability in ImpressPages CMS, published on 22 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2011-4943 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- impresspages/impresspages (Packagist): affected all versions; fixed in 1.0.13\n- impresspages/impresspages (Packagist): affected all versions; fixed in 1.0.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-4943/ (Markdown: https://insights.sbomify.com/CVE-2011-4943/index.md)","id":"CVE-2011-4943","markdown":"https://insights.sbomify.com/CVE-2011-4943/index.md","name":"CVE-2011-4943","record":{"aliases":["GHSA-4xf9-4r44-86rc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"ImpressPages CMS","requires_auth":"none","summary":"Remote attackers can execute arbitrary code on ImpressPages CMS installations, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"impresspages_cms","vendor":"impresspages"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"ImpressPages CMS v1.0.12 has Unspecified Remote Code Execution (fixed in v1.0.13)","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ImpressPages CMS RCE","id":"CVE-2011-4943","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2011"},"n_packages":2,"n_references":1,"next":{"headline":"Race condition in n/a","id":"CVE-2011-4944"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.13"],"introduced":["0"],"last_affected":[],"package":"impresspages/impresspages","purl":null,"source":"GHSA-4xf9-4r44-86rc"},{"ecosystem":"Packagist","fixed":["1.0.13"],"introduced":["0"],"last_affected":[],"package":"impresspages/impresspages","purl":"pkg:composer/impresspages/impresspages","source":"GHSA-4xf9-4r44-86rc"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2011-4942"},"products":["ImpressPages CMS"],"published":"2020-01-22","related":[{"cvss_score":7.5,"headline":"ImpressPages CMS eval injection vulnerability","id":"CVE-2011-4932","kev_date_added":null,"published":"2012-10-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["ImpressPages CMS"]},"summary":"Remote attackers can execute arbitrary code on ImpressPages CMS installations, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2011-4943/"}