# CVE-2011-4943: ImpressPages CMS RCE

> Remote attackers can execute arbitrary code on ImpressPages CMS installations, requiring an upgrade to the latest version.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2020
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-4xf9-4r44-86rc

## What is CVE-2011-4943?

CVE-2011-4943 is a critical code injection vulnerability in ImpressPages CMS, published on 22 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ImpressPages CMS v1.0.12 has Unspecified Remote Code Execution (fixed in v1.0.13)

## Which versions are affected by CVE-2011-4943?

2 open source packages ship an affected version, including impresspages/impresspages. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `impresspages/impresspages` | Packagist | All versions | 1.0.13 |
| `impresspages/impresspages` | Packagist | All versions | 1.0.13 |

Products: Impresspages Impresspages Cms.

## How do I fix CVE-2011-4943?

Upgrade impresspages/impresspages to 1.0.13 or later.

## Is CVE-2011-4943 being exploited?

There is no known exploitation of CVE-2011-4943 in the wild and no public exploit code.

## Other vulnerabilities in ImpressPages CMS

- [CVE-2011-4932](https://insights.sbomify.com/CVE-2011-4932/): ImpressPages CMS eval injection vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4943 and fix it if it is affected.

What it is: CVE-2011-4943 is a critical code injection vulnerability in ImpressPages CMS, published on 22 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-4943 in the wild and no public exploit code.

Affected packages and fixed versions:
- impresspages/impresspages (Packagist): affected all versions; fixed in 1.0.13
- impresspages/impresspages (Packagist): affected all versions; fixed in 1.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4943/ (Markdown: https://insights.sbomify.com/CVE-2011-4943/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4943
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4943
- OSV: https://osv.dev/vulnerability/CVE-2011-4943

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4943/
Summaries are generated and may contain mistakes; the official description above is the record.
