{"answers":{"affected":"3 open source packages ship an affected version, including cobbler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-4952 in the wild and no public exploit code.","fix":"Upgrade cobbler to 2.6.0 or later.","what":"CVE-2011-4952 is a high-severity vulnerability in cobbler, published on 19 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-4952 and fix it if it is affected.\n\nWhat it is: CVE-2011-4952 is a high-severity vulnerability in cobbler, published on 19 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2011-4952 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected all versions; fixed in 2.6.0\n- cobbler (PyPI): affected all versions; fixed in 2.6.0\n- cobbler (PyPI): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-4952/ (Markdown: https://insights.sbomify.com/CVE-2011-4952/index.md)","id":"CVE-2011-4952","markdown":"https://insights.sbomify.com/CVE-2011-4952/index.md","name":"CVE-2011-4952","record":{"aliases":["GHSA-9fqr-pqc9-f7pj","PYSEC-2026-624"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Cobbler web interface","requires_auth":"none","summary":"Attackers can perform unauthorized actions on behalf of authenticated users due to missing CSRF protection in the Cobbler web interface.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cobbler","vendor":"cobblerd"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"cobbler: Web interface lacks CSRF protection when using Django framework","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cobbler Web Interface Lacks CSRF Protection","id":"CVE-2011-4952","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"csrf","year":"2011"},"n_packages":3,"n_references":4,"next":{"headline":"Cobbler vulnerable to code injection via unsafe YAML loading","id":"CVE-2011-4953"},"packages":[{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-9fqr-pqc9-f7pj"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-9fqr-pqc9-f7pj"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2026-624"}],"prev":{"headline":"Open redirect in n/a","id":"CVE-2011-4951"},"products":["cobbler"],"published":"2019-11-19","related":[{"cvss_score":9.8,"headline":"Cobbler Improper Validation of Security Tokens","id":"CVE-2018-1000226","kev_date_added":null,"published":"2018-08-20"},{"cvss_score":7.8,"headline":"Privilege escalation in cobbler","id":"CVE-2011-4954","kev_date_added":null,"published":"2019-11-19"},{"cvss_score":6.1,"headline":"Cobbler XSS Vulnerability","id":"CVE-2018-1000225","kev_date_added":null,"published":"2018-08-20"},{"cvss_score":4,"headline":"Cobbler Path Traversal vulnerability","id":"CVE-2014-3225","kev_date_added":null,"published":"2014-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["cobbler"]},"summary":"Attackers can perform unauthorized actions on behalf of authenticated users due to missing CSRF protection in the Cobbler web interface.","url":"https://insights.sbomify.com/CVE-2011-4952/"}