{"answers":{"affected":"3 open source packages ship an affected version, including cobbler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-4953 in the wild and no public exploit code.","fix":"Upgrade cobbler to 2.6.0 or later.","what":"CVE-2011-4953 is a medium-severity unsafe deserialization vulnerability in n/a, published on 27 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2011-4953 and fix it if it is affected.\n\nWhat it is: CVE-2011-4953 is a medium-severity unsafe deserialization vulnerability in n/a, published on 27 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2011-4953 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected all versions; fixed in 2.6.0\n- cobbler (PyPI): affected all versions; fixed in 2.6.0\n- cobbler (PyPI): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-4953/ (Markdown: https://insights.sbomify.com/CVE-2011-4953/index.md)","id":"CVE-2011-4953","markdown":"https://insights.sbomify.com/CVE-2011-4953/index.md","name":"CVE-2011-4953","record":{"aliases":["GHSA-hpj3-5p46-g87w","PYSEC-2026-793"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Cobbler provisioning server","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code on Cobbler servers by exploiting unsafe YAML deserialization in management parameter settings.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cobbler","vendor":"cobbler_project"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The set_mgmt_parameters function in item.py in cobbler before 2.2.2 allows context-dependent attackers to execute arbitrary code via vectors related to the use of the yaml.load function instead of the yaml.safe_load function, as demonstrated using Puppet.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cobbler vulnerable to code injection via unsafe YAML loading","id":"CVE-2011-4953","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2011"},"n_packages":3,"n_references":3,"next":{"headline":"Privilege escalation in cobbler","id":"CVE-2011-4954"},"packages":[{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-hpj3-5p46-g87w"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-hpj3-5p46-g87w"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2026-793"}],"prev":{"headline":"Cobbler Web Interface Lacks CSRF Protection","id":"CVE-2011-4952"},"products":["n/a"],"published":"2014-10-27","related":[{"cvss_score":9.8,"headline":"Cobbler before 3.3.0 allows log poisoning","id":"CVE-2021-40323","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":9.8,"headline":"Cobbler has Exposed Dangerous Method or Function","id":"CVE-2018-10931","kev_date_added":null,"published":"2018-08-09"},{"cvss_score":9.8,"headline":"Cobbler vulnerable to arbitrary code execution","id":"CVE-2017-1000469","kev_date_added":null,"published":"2018-01-03"},{"cvss_score":8.2,"headline":"Improper Authorization in cobbler/cobbler","id":"CVE-2022-0860","kev_date_added":null,"published":"2022-03-11"},{"cvss_score":7.8,"headline":"Command Injection in Cobbler","id":"CVE-2021-45082","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data.","id":"CVE-2021-40324","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows authorization bypass for modification of settings.","id":"CVE-2021-40325","kev_date_added":null,"published":"2021-10-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code on Cobbler servers by exploiting unsafe YAML deserialization in management parameter settings.","url":"https://insights.sbomify.com/CVE-2011-4953/"}