# CVE-2011-4953: Cobbler vulnerable to code injection via unsafe YAML loading

> Attackers can execute arbitrary code on Cobbler servers by exploiting unsafe YAML deserialization in management parameter settings.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Oct 2014
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-hpj3-5p46-g87w, PYSEC-2026-793

## What is CVE-2011-4953?

CVE-2011-4953 is a medium-severity unsafe deserialization vulnerability in n/a, published on 27 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The set_mgmt_parameters function in item.py in cobbler before 2.2.2 allows context-dependent attackers to execute arbitrary code via vectors related to the use of the yaml.load function instead of the yaml.safe_load function, as demonstrated using Puppet.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2011-4953?

3 open source packages ship an affected version, including cobbler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cobbler` | PyPI | All versions | 2.6.0 |
| `cobbler` | PyPI | All versions | 2.6.0 |
| `cobbler` | PyPI | All versions | 2.6.0 |

Products: Cobbler Project Cobbler.

## How do I fix CVE-2011-4953?

Upgrade cobbler to 2.6.0 or later.

## Is CVE-2011-4953 being exploited?

There is no known exploitation of CVE-2011-4953 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-40323](https://insights.sbomify.com/CVE-2021-40323/): Cobbler before 3.3.0 allows log poisoning (critical 9.8)
- [CVE-2018-10931](https://insights.sbomify.com/CVE-2018-10931/): Cobbler has Exposed Dangerous Method or Function (critical 9.8)
- [CVE-2017-1000469](https://insights.sbomify.com/CVE-2017-1000469/): Cobbler vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2022-0860](https://insights.sbomify.com/CVE-2022-0860/): Improper Authorization in cobbler/cobbler (high 8.2)
- [CVE-2021-45082](https://insights.sbomify.com/CVE-2021-45082/): Command Injection in Cobbler (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4953 and fix it if it is affected.

What it is: CVE-2011-4953 is a medium-severity unsafe deserialization vulnerability in n/a, published on 27 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-4953 in the wild and no public exploit code.

Affected packages and fixed versions:
- cobbler (PyPI): affected all versions; fixed in 2.6.0
- cobbler (PyPI): affected all versions; fixed in 2.6.0
- cobbler (PyPI): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4953/ (Markdown: https://insights.sbomify.com/CVE-2011-4953/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4953
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4953
- OSV: https://osv.dev/vulnerability/CVE-2011-4953

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4953/
Summaries are generated and may contain mistakes; the official description above is the record.
