{"answers":{"affected":"8 open source packages ship an affected version, including org.webjars.npm:jquery, jQuery and jquery-rails. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-4969 in the wild and no public exploit code.","fix":"Upgrade org.webjars.npm:jquery to 1.6.3 or later.","what":"CVE-2011-4969 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 Mar 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-4969 and fix it if it is affected.\n\nWhat it is: CVE-2011-4969 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 Mar 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2011-4969 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.webjars.npm:jquery (Maven): affected all versions; fixed in 1.6.3\n- org.webjars.npm:jquery (Maven): affected all versions; fixed in 1.6.3\n- jQuery (NuGet): affected all versions; fixed in 1.6.3\n- jQuery (NuGet): affected all versions; fixed in 1.6.3\n- jquery-rails (RubyGems): affected all versions; fixed in 1.0.16\n- jquery-rails (RubyGems): affected all versions; fixed in 1.0.16\n- jquery (npm): affected all versions; fixed in 1.6.3\n- jquery (npm): affected all versions; fixed in 1.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-4969/ (Markdown: https://insights.sbomify.com/CVE-2011-4969/index.md)","id":"CVE-2011-4969","markdown":"https://insights.sbomify.com/CVE-2011-4969/index.md","name":"CVE-2011-4969","record":{"aliases":["AZL-44421","CVE-2013-5989","GHSA-579v-mp3v-rrw5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript library","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via crafted tags when using location.hash, affecting applications using vulnerable jQuery versions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"jquery","vendor":"jquery"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in jQuery before 1.6.3, when using location.hash to select elements, allows remote attackers to inject arbitrary web script or HTML via a crafted tag.","ecosystems":["Maven","NuGet","RubyGems","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"jQuery vulnerable to Cross-Site Scripting (XSS)","id":"CVE-2011-4969","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2011"},"n_packages":8,"n_references":14,"next":{"headline":"SQL injection in n/a","id":"CVE-2011-4970"},"packages":[{"ecosystem":"Maven","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"org.webjars.npm:jquery","purl":null,"source":"GHSA-579v-mp3v-rrw5"},{"ecosystem":"Maven","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"org.webjars.npm:jquery","purl":"pkg:maven/org.webjars.npm/jquery","source":"GHSA-579v-mp3v-rrw5"},{"ecosystem":"NuGet","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"jQuery","purl":null,"source":"GHSA-579v-mp3v-rrw5"},{"ecosystem":"NuGet","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"jQuery","purl":"pkg:nuget/jQuery","source":"GHSA-579v-mp3v-rrw5"},{"ecosystem":"RubyGems","fixed":["1.0.16"],"introduced":["0"],"last_affected":[],"package":"jquery-rails","purl":null,"source":"GHSA-579v-mp3v-rrw5"},{"ecosystem":"RubyGems","fixed":["1.0.16"],"introduced":["0"],"last_affected":[],"package":"jquery-rails","purl":"pkg:gem/jquery-rails","source":"GHSA-579v-mp3v-rrw5"},{"ecosystem":"npm","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"jquery","purl":null,"source":"GHSA-579v-mp3v-rrw5"},{"ecosystem":"npm","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"jquery","purl":"pkg:npm/jquery","source":"GHSA-579v-mp3v-rrw5"}],"prev":{"headline":"Security feature bypass in nginx","id":"CVE-2011-4968"},"products":["n/a"],"published":"2013-03-08","related":[{"cvss_score":7.5,"headline":"Denial of Service in jquery","id":"CVE-2016-10707","kev_date_added":null,"published":"2018-01-18"},{"cvss_score":6.1,"headline":"Cross-Site Scripting in jquery","id":"CVE-2020-7656","kev_date_added":null,"published":"2020-05-19"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2018-18405","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":6.1,"headline":"Cross-Site Scripting in jquery","id":"CVE-2012-6708","kev_date_added":null,"published":"2018-01-18"},{"cvss_score":6.1,"headline":"Cross-Site Scripting (XSS) in jquery","id":"CVE-2015-9251","kev_date_added":null,"published":"2018-01-18"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2014-6071","kev_date_added":null,"published":"2018-01-16"},{"cvss_score":5,"headline":"Information disclosure in n/a","id":"CVE-2007-2379","kev_date_added":null,"published":"2007-04-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via crafted tags when using location.hash, affecting applications using vulnerable jQuery versions.","url":"https://insights.sbomify.com/CVE-2011-4969/"}