# CVE-2011-5036: Rack Gem Subject to Denial of Service via Hash Collisions

> Remote attackers can cause denial of service via CPU exhaustion by sending crafted form parameters that trigger hash collisions in the Rack library.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2011
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2011-5036, GHSA-v6j3-7jrw-hq2p

## What is CVE-2011-5036?

CVE-2011-5036 is a medium-severity denial of service vulnerability in n/a, published on 30 Dec 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack before 1.1.3, 1.2.x before 1.2.5, and 1.3.x before 1.3.6 computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters.

Weakness: CWE-310

## Which versions are affected by CVE-2011-5036?

8 open source packages ship an affected version, including rack and org.jruby:jruby-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 1.1.3 |
| `rack` | RubyGems | All versions | 1.1.3 |
| `rack` | RubyGems | From 1.2.0 | 1.2.5 |
| `rack` | RubyGems | From 1.2.0 | 1.2.5 |
| `rack` | RubyGems | From 1.3.0 | 1.3.6 |
| `rack` | RubyGems | From 1.3.0 | 1.3.6 |
| `org.jruby:jruby-parent` | Maven | All versions | 1.6.5.1 |
| `org.jruby:jruby-parent` | Maven | All versions | 1.6.5.1 |

Products: Rack Project Rack.

## How do I fix CVE-2011-5036?

Upgrade rack to a fixed version for your release line: 1.1.3, 1.2.5 or 1.3.6.

## Is CVE-2011-5036 being exploited?

There is no known exploitation of CVE-2011-5036 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-16470](https://insights.sbomify.com/CVE-2018-16470/): Rack vulnerable to Denial of Service (high 7.5)
- [CVE-2013-0263](https://insights.sbomify.com/CVE-2013-0263/): Rack arbitrary code execution via timing attack (medium 5.1)
- [CVE-2013-0183](https://insights.sbomify.com/CVE-2013-0183/): Rack rubygems receiving excessively long lines triggers out-of-memory error (medium 5.0)
- [CVE-2012-6109](https://insights.sbomify.com/CVE-2012-6109/): Rack vulnerable to REDoS (medium 4.3)
- [CVE-2013-0184](https://insights.sbomify.com/CVE-2013-0184/): Rack vulnerable to Denial of Service (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-5036 and fix it if it is affected.

What it is: CVE-2011-5036 is a medium-severity denial of service vulnerability in n/a, published on 30 Dec 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-5036 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 1.1.3
- rack (RubyGems): affected all versions; fixed in 1.1.3
- rack (RubyGems): affected from 1.2.0; fixed in 1.2.5
- rack (RubyGems): affected from 1.2.0; fixed in 1.2.5
- rack (RubyGems): affected from 1.3.0; fixed in 1.3.6
- rack (RubyGems): affected from 1.3.0; fixed in 1.3.6
- org.jruby:jruby-parent (Maven): affected all versions; fixed in 1.6.5.1
- org.jruby:jruby-parent (Maven): affected all versions; fixed in 1.6.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-5036/ (Markdown: https://insights.sbomify.com/CVE-2011-5036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-5036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-5036
- OSV: https://osv.dev/vulnerability/CVE-2011-5036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-5036/
Summaries are generated and may contain mistakes; the official description above is the record.
