CVE-2011-5062 Improper Authentication in Apache Tomcat
Remote attackers can bypass HTTP Digest Access Authentication integrity checks by manipulating qop values in Apache Tomcat.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-5062?
CVE-2011-5062 is a medium-severity vulnerability in Apache Tomcat, published on 14 Jan 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The HTTP Digest Access Authentication implementation in Apache Tomcat 5.5.x before 5.5.34, 6.x before 6.0.33, and 7.x before 7.0.12 does not check qop values, which might allow remote attackers to bypass intended integrity-protection requirements via a qop=auth value, a different vulnerability than CVE-2011-1184.
Weakness: CWE-264
Which versions are affected by CVE-2011-5062?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.34 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.34 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.33 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.33 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.12 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.12 |
Products include Apache Tomcat.
How do I fix CVE-2011-5062?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.34, 6.0.33 or 7.0.12.
Is CVE-2011-5062 being exploited?
There is no known exploitation of CVE-2011-5062 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-4f7h-9j2x-cmr4.