# CVE-2011-5063: Improper Authentication in Apache Tomcat

> Remote attackers can bypass access restrictions in Apache Tomcat by exploiting unchecked realm values in HTTP Digest Authentication when weaker protection spaces are available.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2012
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-hffm-fqv4-w27r

## What is CVE-2011-5063?

CVE-2011-5063 is a medium-severity authentication bypass vulnerability in Apache Tomcat, published on 14 Jan 2012. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The HTTP Digest Access Authentication implementation in Apache Tomcat 5.5.x before 5.5.34, 6.x before 6.0.33, and 7.x before 7.0.12 does not check realm values, which might allow remote attackers to bypass intended access restrictions by leveraging the availability of a protection space with weaker authentication or authorization requirements, a different vulnerability than CVE-2011-1184.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2011-5063?

6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.34 |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.34 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.33 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.33 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.12 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.12 |

Products: Apache Tomcat.

## How do I fix CVE-2011-5063?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.34, 6.0.33 or 7.0.12.

## Is CVE-2011-5063 being exploited?

There is no known exploitation of CVE-2011-5063 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-5063 and fix it if it is affected.

What it is: CVE-2011-5063 is a medium-severity authentication bypass vulnerability in Apache Tomcat, published on 14 Jan 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-5063 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.34
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.34
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.33
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.33
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.12
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-5063/ (Markdown: https://insights.sbomify.com/CVE-2011-5063/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-5063
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-5063
- OSV: https://osv.dev/vulnerability/CVE-2011-5063

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-5063/
Summaries are generated and may contain mistakes; the official description above is the record.
