CVE-2012-0022 Denial of Service in Apache Tomcat
Remote attackers can cause denial of service via CPU consumption by sending requests with many parameters in Apache Tomcat.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-0022?
CVE-2012-0022 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 19 Jan 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Tomcat 5.5.x before 5.5.35, 6.x before 6.0.34, and 7.x before 7.0.23 uses an inefficient approach for handling parameters, which allows remote attackers to cause a denial of service (CPU consumption) via a request that contains many parameters and parameter values, a different vulnerability than CVE-2011-4858.
Weakness: CWE-189
Which versions are affected by CVE-2012-0022?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.35 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.35 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.34 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.34 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.23 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.23 |
Products include Apache Tomcat.
How do I fix CVE-2012-0022?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.35, 6.0.34 or 7.0.23.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2012-0022 being exploited?
There is no known exploitation of CVE-2012-0022 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-8h2q-qm9x-55jc.