# CVE-2012-0391: Apache Struts 2 Improper Input Validation

> Remote attackers can execute arbitrary Java code via crafted parameters due to unsafe OGNL expression evaluation in exception handling.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 21 Jan 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2012
- **Updated:** 22 Oct 2025
- **Also known as:** GHSA-4wrr-9h5r-m92w

## What is CVE-2012-0391?

CVE-2012-0391 is a critical code injection vulnerability in Apache Struts, published on 8 Jan 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter values as OGNL expressions during certain exception handling for mismatched data types of properties, which allows remote attackers to execute arbitrary Java code via a crafted parameter.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2012-0391?

4 open source packages ship an affected version, including org.apache.struts.xwork:xwork-core and org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts.xwork:xwork-core` | Maven | All versions | 2.2.3.1 |
| `org.apache.struts.xwork:xwork-core` | Maven | All versions | 2.2.3.1 |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.2.3.1 |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.2.3.1 |

Products: Apache Struts.

## How do I fix CVE-2012-0391?

Upgrade org.apache.struts.xwork:xwork-core to 2.2.3.1 or later. US federal agencies must fix it by 21 Jul 2022.

## Is CVE-2012-0391 being exploited?

Yes. Attackers have exploited CVE-2012-0391 in the wild since at least 21 Jan 2022.

Public exploit code:

- Apache Struts 2 < 2.3.1 - Multiple Vulnerabilities (exploitdb)
- Apache Struts Remote Command Execution (metasploit)
- Apache Struts 2.2.1.1 - Remote Command Execution (Metasploit) (exploitdb)

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-9805](https://insights.sbomify.com/CVE-2017-9805/): Apache Struts Deserialization of Untrusted Data (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-0391 and fix it if it is affected.

What it is: CVE-2012-0391 is a critical code injection vulnerability in Apache Struts, published on 8 Jan 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2012-0391 in the wild since at least 21 Jan 2022.

Affected packages and fixed versions:
- org.apache.struts.xwork:xwork-core (Maven): affected all versions; fixed in 2.2.3.1
- org.apache.struts.xwork:xwork-core (Maven): affected all versions; fixed in 2.2.3.1
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.2.3.1
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-0391/ (Markdown: https://insights.sbomify.com/CVE-2012-0391/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-0391
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-0391
- OSV: https://osv.dev/vulnerability/CVE-2012-0391

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-0391/
Summaries are generated and may contain mistakes; the official description above is the record.
