# CVE-2012-0393: Apache Struts's ParameterInterceptor component does not prevent access to public constructors

> Remote attackers can execute arbitrary code or overwrite files by exploiting improper access controls in Apache Struts parameter handling.

- **Severity:** Medium 6.4 (`AV:N/AC:L/Au:N/C:N/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2012
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-hxqq-w4mr-mc62

## What is CVE-2012-0393?

CVE-2012-0393 is a medium-severity code injection vulnerability in Apache Struts, published on 8 Jan 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The ParameterInterceptor component in Apache Struts before 2.3.1.1 does not prevent access to public constructors, which allows remote attackers to create or overwrite arbitrary files via a crafted parameter that triggers the creation of a Java object.

Weakness: CWE-264

## Which versions are affected by CVE-2012-0393?

4 open source packages ship an affected version, including org.apache.struts.xwork:xwork-core and org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts.xwork:xwork-core` | Maven | All versions | 2.2.3.1 |
| `org.apache.struts.xwork:xwork-core` | Maven | All versions | 2.2.3.1 |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.3.1.1 |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.3.1.1 |

Products: Apache Struts.

## How do I fix CVE-2012-0393?

Upgrade org.apache.struts.xwork:xwork-core to 2.2.3.1 or later.

## Is CVE-2012-0393 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2012-0393 exists.

Public exploit code:

- Apache Struts 2 < 2.3.1 - Multiple Vulnerabilities (exploitdb)

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-0393 and fix it if it is affected.

What it is: CVE-2012-0393 is a medium-severity code injection vulnerability in Apache Struts, published on 8 Jan 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2012-0393 exists.

Affected packages and fixed versions:
- org.apache.struts.xwork:xwork-core (Maven): affected all versions; fixed in 2.2.3.1
- org.apache.struts.xwork:xwork-core (Maven): affected all versions; fixed in 2.2.3.1
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.3.1.1
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-0393/ (Markdown: https://insights.sbomify.com/CVE-2012-0393/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-0393
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-0393
- OSV: https://osv.dev/vulnerability/CVE-2012-0393

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-0393/
Summaries are generated and may contain mistakes; the official description above is the record.
