# CVE-2012-0394: Apache Struts's DebuggingInterceptor component allows remote code execution in developer mode

> Remote attackers can execute arbitrary commands in Apache Struts when developer mode is enabled, requiring an upgrade to secure the application.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-hmvj-gc9q-mg9p

## What is CVE-2012-0394?

CVE-2012-0394 is a medium-severity command injection vulnerability in Apache Struts, published on 8 Jan 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The DebuggingInterceptor component in Apache Struts before 2.3.1.1, when developer mode is used, allows remote attackers to execute arbitrary commands via unspecified vectors.  NOTE: the vendor characterizes this behavior as not "a security vulnerability itself.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2012-0394?

2 open source packages ship an affected version, including org.apache.struts.xwork:xwork-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts.xwork:xwork-core` | Maven | All versions | 2.3.18 |
| `org.apache.struts.xwork:xwork-core` | Maven | All versions | 2.3.18 |

Products: Apache Struts.

## How do I fix CVE-2012-0394?

Upgrade org.apache.struts.xwork:xwork-core to 2.3.18 or later.

## Is CVE-2012-0394 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2012-0394 exists.

Public exploit code:

- Apache Struts 2 < 2.3.1 - Multiple Vulnerabilities (exploitdb)
- Apache Struts 2 Developer Mode OGNL Execution (metasploit)
- Apache Struts - Developer Mode OGNL Execution (Metasploit) (exploitdb)
- Apache Struts <2.3.1.1 - Remote Code Execution (nuclei): http/cves/2012/CVE-2012-0394.yaml

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-0394 and fix it if it is affected.

What it is: CVE-2012-0394 is a medium-severity command injection vulnerability in Apache Struts, published on 8 Jan 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2012-0394 exists.

Affected packages and fixed versions:
- org.apache.struts.xwork:xwork-core (Maven): affected all versions; fixed in 2.3.18
- org.apache.struts.xwork:xwork-core (Maven): affected all versions; fixed in 2.3.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-0394/ (Markdown: https://insights.sbomify.com/CVE-2012-0394/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-0394
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-0394
- OSV: https://osv.dev/vulnerability/CVE-2012-0394

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-0394/
Summaries are generated and may contain mistakes; the official description above is the record.
