# CVE-2012-0796: PHPMailer vulnerable to email header injection

> Authenticated users can inject arbitrary email headers in PHPMailer, potentially altering email metadata or bypassing filters.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-398j-f7m7-795j

## What is CVE-2012-0796?

CVE-2012-0796 is a medium-severity vulnerability in Moodle Moodle, published on 17 Jul 2012. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

class.phpmailer.php in the PHPMailer library, as used in Moodle 1.9.x before 1.9.16, 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 and other products, allows remote authenticated users to inject arbitrary e-mail headers via vectors involving a crafted (1) From: or (2) Sender: header.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2012-0796?

2 open source packages ship an affected version, including phpmailer/phpmailer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmailer/phpmailer` | Packagist | All versions | 2.2.1 |
| `phpmailer/phpmailer` | Packagist | All versions | 2.2.1 |

Products: Moodle Moodle.

## How do I fix CVE-2012-0796?

Upgrade phpmailer/phpmailer to 2.2.1 or later.

## Is CVE-2012-0796 being exploited?

There is no known exploitation of CVE-2012-0796 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-0796 and fix it if it is affected.

What it is: CVE-2012-0796 is a medium-severity vulnerability in Moodle Moodle, published on 17 Jul 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-0796 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmailer/phpmailer (Packagist): affected all versions; fixed in 2.2.1
- phpmailer/phpmailer (Packagist): affected all versions; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-0796/ (Markdown: https://insights.sbomify.com/CVE-2012-0796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-0796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-0796
- OSV: https://osv.dev/vulnerability/CVE-2012-0796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-0796/
Summaries are generated and may contain mistakes; the official description above is the record.
