CVE-2012-0797 Moodle Users Can Bypass Deleted Status
Authenticated users can bypass account deletion status and continue accessing the server via token in Moodle webservices.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-0797?
CVE-2012-0797 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 17 Jul 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to bypass the deleted status and continue using a server via a token.
Weakness: CWE-16
Which versions are affected by CVE-2012-0797?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.0 | 2.0.7 |
moodle/moodle Packagist | From 2.0 | 2.0.7 |
moodle/moodle Packagist | From 2.1 | 2.1.4 |
moodle/moodle Packagist | From 2.1 | 2.1.4 |
moodle/moodle Packagist | From 2.2 | 2.2.1 |
moodle/moodle Packagist | From 2.2 | 2.2.1 |
Products include Moodle Moodle.
How do I fix CVE-2012-0797?
Upgrade moodle/moodle to a fixed version for your release line: 2.0.7, 2.1.4 or 2.2.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2012-0797 being exploited?
There is no known exploitation of CVE-2012-0797 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-72gv-qqrp-h9qg.