{"answers":{"affected":"3 open source packages ship an affected version, including sqlalchemy and SQLAlchemy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-0805 in the wild and no public exploit code.","fix":"Upgrade sqlalchemy to a fixed version for your release line: 0.7.0 or 0.7.0b4.","what":"CVE-2012-0805 is a high-severity SQL injection vulnerability in n/a, published on 5 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-0805 and fix it if it is affected.\n\nWhat it is: CVE-2012-0805 is a high-severity SQL injection vulnerability in n/a, published on 5 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-0805 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sqlalchemy (PyPI): affected all versions; fixed in 0.7.0\n- sqlalchemy (PyPI): affected all versions; fixed in 0.7.0b4\n- SQLAlchemy (PyPI): affected all versions; fixed in 0.7.0b4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-0805/ (Markdown: https://insights.sbomify.com/CVE-2012-0805/index.md)","id":"CVE-2012-0805","markdown":"https://insights.sbomify.com/CVE-2012-0805/index.md","name":"CVE-2012-0805","record":{"aliases":["DEBIAN-CVE-2012-0805","DSA-2449-1","GHSA-hfg2-wf6j-x53p","PYSEC-2012-9","RHSA-2012:0369"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Python SQL library","requires_auth":"none","summary":"Remote attackers can execute arbitrary SQL commands via crafted limit or offset parameters in SQLAlchemy select functions.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"sqlalchemy","vendor":"sqlalchemy"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Multiple SQL injection vulnerabilities in SQLAlchemy before 0.7.0b4, as used in Keystone, allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset keyword to the select function, or unspecified vectors to the (3) select.limit or (4) select.offset function.","ecosystems":["PyPI","Red Hat:enterprise_linux:6::server","Red Hat:enterprise_linux:6::workstation"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQLAlchemy vulnerable to SQL injection","id":"CVE-2012-0805","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2012"},"n_packages":5,"n_references":10,"next":{"headline":"Memory corruption in n/a","id":"CVE-2012-0806"},"packages":[{"ecosystem":"PyPI","fixed":["0.7.0b4"],"introduced":["0"],"last_affected":[],"package":"SQLAlchemy","purl":null,"source":"GHSA-hfg2-wf6j-x53p"},{"ecosystem":"PyPI","fixed":["0.7.0"],"introduced":["0"],"last_affected":[],"package":"sqlalchemy","purl":"pkg:pypi/sqlalchemy","source":"PYSEC-2012-9"},{"ecosystem":"PyPI","fixed":["0.7.0b4"],"introduced":["0"],"last_affected":[],"package":"sqlalchemy","purl":"pkg:pypi/sqlalchemy","source":"GHSA-hfg2-wf6j-x53p"},{"ecosystem":"Red Hat:enterprise_linux:6::server","fixed":["0:0.5.5-3.el6_2"],"introduced":["0"],"last_affected":[],"package":"python-sqlalchemy","purl":"pkg:rpm/redhat/python-sqlalchemy","source":"RHSA-2012:0369"},{"ecosystem":"Red Hat:enterprise_linux:6::workstation","fixed":["0:0.5.5-3.el6_2"],"introduced":["0"],"last_affected":[],"package":"python-sqlalchemy","purl":"pkg:rpm/redhat/python-sqlalchemy","source":"RHSA-2012:0369"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2012-0804"},"products":["n/a"],"published":"2012-06-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary SQL commands via crafted limit or offset parameters in SQLAlchemy select functions.","url":"https://insights.sbomify.com/CVE-2012-0805/"}