# CVE-2012-0838: Apache Struts Code injection due to conversion error

> Remote attackers can execute arbitrary code by sending invalid input to a field, exploiting OGNL expression evaluation during conversion errors.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Mar 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-mwrx-hx6x-3hhv

## What is CVE-2012-0838?

CVE-2012-0838 is a critical code injection vulnerability in Apache Struts, published on 2 Mar 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Struts 2 before 2.2.3.1 evaluates a string as an OGNL expression during the handling of a conversion error, which allows remote attackers to modify run-time data values, and consequently execute arbitrary code, via invalid input to a field.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2012-0838?

4 open source packages ship an affected version, including org.apache.struts.xwork:xwork-core and org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts.xwork:xwork-core` | Maven | All versions | 2.2.3.1 |
| `org.apache.struts.xwork:xwork-core` | Maven | All versions | 2.2.3.1 |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.2.3.1 |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.2.3.1 |

Products: Apache Struts.

## How do I fix CVE-2012-0838?

Upgrade org.apache.struts.xwork:xwork-core to 2.2.3.1 or later.

## Is CVE-2012-0838 being exploited?

There is no known exploitation of CVE-2012-0838 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-0838 and fix it if it is affected.

What it is: CVE-2012-0838 is a critical code injection vulnerability in Apache Struts, published on 2 Mar 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-0838 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts.xwork:xwork-core (Maven): affected all versions; fixed in 2.2.3.1
- org.apache.struts.xwork:xwork-core (Maven): affected all versions; fixed in 2.2.3.1
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.2.3.1
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-0838/ (Markdown: https://insights.sbomify.com/CVE-2012-0838/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-0838
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-0838
- OSV: https://osv.dev/vulnerability/CVE-2012-0838

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-0838/
Summaries are generated and may contain mistakes; the official description above is the record.
