{"answers":{"affected":"6 open source packages ship an affected version, including paste and pastescript. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-0878 in the wild and no public exploit code.","fix":"Upgrade paste to 1.7.5.1 or later.","what":"CVE-2012-0878 is a medium-severity vulnerability in n/a, published on 1 May 2012. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-0878 and fix it if it is affected.\n\nWhat it is: CVE-2012-0878 is a medium-severity vulnerability in n/a, published on 1 May 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-0878 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paste (PyPI): affected all versions; fixed in 1.7.5.1\n- paste (PyPI): affected all versions; fixed in 1.7.5.1\n- paste (PyPI): affected all versions; fixed in 1.7.5.1\n- pastescript (PyPI): affected all versions; fixed in 2.0.1\n- pastescript (PyPI): affected all versions; fixed in 2.0.1\n- pastescript (PyPI): affected all versions; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-0878/ (Markdown: https://insights.sbomify.com/CVE-2012-0878/index.md)","id":"CVE-2012-0878","markdown":"https://insights.sbomify.com/CVE-2012-0878/index.md","name":"CVE-2012-0878","record":{"aliases":["DEBIAN-CVE-2012-0878","GHSA-27px-qpmj-qg38","PYSEC-2012-15","PYSEC-2026-2859","RHSA-2012:1206"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Python web framework","requires_auth":"none","summary":"Remote attackers can bypass file-access restrictions and escalate privileges in Paste Script applications running with root privileges.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"paste","vendor":"pythonpaste"}],"cvss":{"score":5.1,"severity":"medium","source":"nvd","vector":"AV:N/AC:H/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"Paste Script 1.7.5 and earlier does not properly set group memberships during execution with root privileges, which might allow remote attackers to bypass intended file-access restrictions by leveraging a web application that uses the local filesystem.","ecosystems":["PyPI","Red Hat:enterprise_linux:6::server","Red Hat:enterprise_linux:6::workstation"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Paste Script has improper group memberships permissions","id":"CVE-2012-0878","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2012"},"n_packages":8,"n_references":9,"next":{"headline":"Denial of service in n/a","id":"CVE-2012-0879"},"packages":[{"ecosystem":"PyPI","fixed":["1.7.5.1"],"introduced":["0"],"last_affected":[],"package":"paste","purl":null,"source":"GHSA-27px-qpmj-qg38"},{"ecosystem":"PyPI","fixed":["1.7.5.1"],"introduced":["0"],"last_affected":[],"package":"paste","purl":"pkg:pypi/paste","source":"GHSA-27px-qpmj-qg38"},{"ecosystem":"PyPI","fixed":["1.7.5.1"],"introduced":["0"],"last_affected":[],"package":"paste","purl":"pkg:pypi/paste","source":"PYSEC-2012-15"},{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"pastescript","purl":null,"source":"GHSA-27px-qpmj-qg38"},{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"pastescript","purl":"pkg:pypi/pastescript","source":"GHSA-27px-qpmj-qg38"},{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"pastescript","purl":"pkg:pypi/pastescript","source":"PYSEC-2026-2859"},{"ecosystem":"Red Hat:enterprise_linux:6::server","fixed":["0:1.7.3-5.el6_3"],"introduced":["0"],"last_affected":[],"package":"python-paste-script","purl":"pkg:rpm/redhat/python-paste-script","source":"RHSA-2012:1206"},{"ecosystem":"Red Hat:enterprise_linux:6::workstation","fixed":["0:1.7.3-5.el6_3"],"introduced":["0"],"last_affected":[],"package":"python-paste-script","purl":"pkg:rpm/redhat/python-paste-script","source":"RHSA-2012:1206"}],"prev":{"headline":"Denial of service in PyXML","id":"CVE-2012-0877"},"products":["n/a"],"published":"2012-05-01","related":[{"cvss_score":4.3,"headline":"Paste is vulnerable to Cross-site Scripting via vectors involving a 404 status code","id":"CVE-2010-2477","kev_date_added":null,"published":"2010-11-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can bypass file-access restrictions and escalate privileges in Paste Script applications running with root privileges.","url":"https://insights.sbomify.com/CVE-2012-0878/"}