# CVE-2012-0878: Paste Script has improper group memberships permissions

> Remote attackers can bypass file-access restrictions and escalate privileges in Paste Script applications running with root privileges.

- **Severity:** Medium 5.1 (`AV:N/AC:H/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-0878, GHSA-27px-qpmj-qg38, PYSEC-2012-15, PYSEC-2026-2859, RHSA-2012:1206

## What is CVE-2012-0878?

CVE-2012-0878 is a medium-severity vulnerability in n/a, published on 1 May 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Paste Script 1.7.5 and earlier does not properly set group memberships during execution with root privileges, which might allow remote attackers to bypass intended file-access restrictions by leveraging a web application that uses the local filesystem.

Weakness: CWE-264

## Which versions are affected by CVE-2012-0878?

6 open source packages ship an affected version, including paste and pastescript. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paste` | PyPI | All versions | 1.7.5.1 |
| `paste` | PyPI | All versions | 1.7.5.1 |
| `paste` | PyPI | All versions | 1.7.5.1 |
| `pastescript` | PyPI | All versions | 2.0.1 |
| `pastescript` | PyPI | All versions | 2.0.1 |
| `pastescript` | PyPI | All versions | 2.0.1 |
| `python-paste-script` | Red Hat:enterprise_linux:6::server | All versions | 0:1.7.3-5.el6_3 |
| `python-paste-script` | Red Hat:enterprise_linux:6::workstation | All versions | 0:1.7.3-5.el6_3 |

Products: Pythonpaste Paste.

## How do I fix CVE-2012-0878?

Upgrade paste to 1.7.5.1 or later.

## Is CVE-2012-0878 being exploited?

There is no known exploitation of CVE-2012-0878 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2010-2477](https://insights.sbomify.com/CVE-2010-2477/): Paste is vulnerable to Cross-site Scripting via vectors involving a 404 status code (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-0878 and fix it if it is affected.

What it is: CVE-2012-0878 is a medium-severity vulnerability in n/a, published on 1 May 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-0878 in the wild and no public exploit code.

Affected packages and fixed versions:
- paste (PyPI): affected all versions; fixed in 1.7.5.1
- paste (PyPI): affected all versions; fixed in 1.7.5.1
- paste (PyPI): affected all versions; fixed in 1.7.5.1
- pastescript (PyPI): affected all versions; fixed in 2.0.1
- pastescript (PyPI): affected all versions; fixed in 2.0.1
- pastescript (PyPI): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-0878/ (Markdown: https://insights.sbomify.com/CVE-2012-0878/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-0878
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-0878
- OSV: https://osv.dev/vulnerability/CVE-2012-0878

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-0878/
Summaries are generated and may contain mistakes; the official description above is the record.
