# CVE-2012-0881: Denial of service in Apache Xerces2

> Remote attackers can cause denial of service via CPU consumption in Apache Xerces2 Java Parser through crafted XML messages triggering hash collisions.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Oct 2017
- **Updated:** 6 Aug 2024
- **Also known as:** CLEANSTART-2026-WR59127, DEBIAN-CVE-2012-0881, GHSA-vmqm-g3vh-847m, UBUNTU-CVE-2012-0881

## What is CVE-2012-0881?

CVE-2012-0881 is a high-severity denial of service vulnerability in n/a, published on 30 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Xerces2 Java Parser before 2.12.0 allows remote attackers to cause a denial of service (CPU consumption) via a crafted message to an XML service, which triggers hash table collisions.

Weakness: CWE-399

## Which versions are affected by CVE-2012-0881?

2 open source packages ship an affected version, including xerces:xercesImpl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xerces:xercesImpl` | Maven | All versions | 2.12.0 |
| `xerces:xercesImpl` | Maven | All versions | 2.12.0 |

Products: Apache Xerces2 Java.

## How do I fix CVE-2012-0881?

Upgrade xerces:xercesImpl to 2.12.0 or later.

## Is CVE-2012-0881 being exploited?

There is no known exploitation of CVE-2012-0881 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-4002](https://insights.sbomify.com/CVE-2013-4002/): Missing XML Validation in Apache Xerces2 (high 7.1)
- [CVE-2009-2625](https://insights.sbomify.com/CVE-2009-2625/): Denial of service in Apache Xerces2 (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-0881 and fix it if it is affected.

What it is: CVE-2012-0881 is a high-severity denial of service vulnerability in n/a, published on 30 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-0881 in the wild and no public exploit code.

Affected packages and fixed versions:
- xerces:xercesImpl (Maven): affected all versions; fixed in 2.12.0
- xerces:xercesImpl (Maven): affected all versions; fixed in 2.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-0881/ (Markdown: https://insights.sbomify.com/CVE-2012-0881/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-0881
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-0881
- OSV: https://osv.dev/vulnerability/CVE-2012-0881

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-0881/
Summaries are generated and may contain mistakes; the official description above is the record.
