{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-10007 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2012-10007 yet. Limit exposure of the affected software until one is available.","what":"CVE-2012-10007 is a low-severity cross-site scripting vulnerability in madgicweb BuddyStream Plugin, published on 19 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2012-10007 and fix it if it is affected.\n\nWhat it is: CVE-2012-10007 is a low-severity cross-site scripting vulnerability in madgicweb BuddyStream Plugin, published on 19 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2012-10007 in the wild and no public exploit code.\n\nAffected product: madgicweb BuddyStream Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-10007/ (Markdown: https://insights.sbomify.com/CVE-2012-10007/index.md)","id":"CVE-2012-10007","markdown":"https://insights.sbomify.com/CVE-2012-10007/index.md","name":"CVE-2012-10007","record":{"aliases":["GHSA-4v3f-x74x-h275"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via the ShareBox.php file in the BuddyStream WordPress plugin, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"buddystream","vendor":"buddystream_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in madgicweb BuddyStream Plugin up to 3.2.7 on WordPress. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file ShareBox.php. The manipulation of the argument content/link/shares leads to cross site scripting. The attack can be launched remotely. Upgrading to version 3.2.8 is able to address this issue. The patch is named 7d5b9a89a27711aad76fd55ab4cc4185b545a1d0. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-221479.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"madgicweb BuddyStream Plugin ShareBox.php cross site scripting","id":"CVE-2012-10007","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2012"},"n_packages":0,"n_references":4,"next":{"headline":"uakfdotb oneapp sql injection","id":"CVE-2012-10008"},"packages":[],"prev":{"headline":"ale7714 sigeprosi sql injection","id":"CVE-2012-10006"},"products":["BuddyStream Plugin"],"published":"2023-02-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["madgicweb"]},"summary":"Remote attackers can inject malicious scripts via the ShareBox.php file in the BuddyStream WordPress plugin, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2012-10007/"}