{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-10009 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2012-10009 yet. Limit exposure of the affected software until one is available.","what":"CVE-2012-10009 is a high-severity SQL injection vulnerability in 404like Plugin, published on 20 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-10009 and fix it if it is affected.\n\nWhat it is: CVE-2012-10009 is a high-severity SQL injection vulnerability in 404like Plugin, published on 20 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-10009 in the wild and no public exploit code.\n\nAffected product: 404like Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-10009/ (Markdown: https://insights.sbomify.com/CVE-2012-10009/index.md)","id":"CVE-2012-10009","markdown":"https://insights.sbomify.com/CVE-2012-10009/index.md","name":"CVE-2012-10009","record":{"aliases":["GHSA-583v-9qpc-hx7x"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"A SQL injection vulnerability in the 404like WordPress plugin allows remote attackers to manipulate the searchWord argument to access or modify database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"404like","vendor":"404like_project"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A vulnerability was found in 404like Plugin up to 1.0.2 on WordPress. It has been classified as critical. Affected is the function checkPage of the file 404Like.php. The manipulation of the argument searchWord leads to sql injection. It is possible to launch the attack remotely. Upgrading to version 1.0.2 is able to address this issue. The name of the patch is 2c4b589d27554910ab1fd104ddbec9331b540f7f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-223404.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"404like Plugin 404Like.php checkPage sql injection","id":"CVE-2012-10009","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"sql_injection","year":"2012"},"n_packages":0,"n_references":4,"next":{"headline":"BestWebSoft Contact Form contact_form.php cntctfrm_settings_page cross-site request forgery","id":"CVE-2012-10010"},"packages":[],"prev":{"headline":"uakfdotb oneapp sql injection","id":"CVE-2012-10008"},"products":["404like Plugin"],"published":"2023-03-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"A SQL injection vulnerability in the 404like WordPress plugin allows remote attackers to manipulate the searchWord argument to access or modify database contents.","url":"https://insights.sbomify.com/CVE-2012-10009/"}