# CVE-2012-10011: HD FLV PLayer Plugin functions.php hd_update_media sql injection

> Remote attackers can exploit SQL injection in the HD FLV Player Plugin to read or modify database contents.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Apr 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-7jrm-37ff-g3mp

## What is CVE-2012-10011?

CVE-2012-10011 is a medium-severity SQL injection vulnerability in HD FLV PLayer Plugin, published on 9 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in HD FLV PLayer Plugin up to 1.7 on WordPress. It has been rated as critical. Affected by this issue is the function hd_add_media/hd_update_media of the file functions.php. The manipulation of the argument name leads to sql injection. The attack may be launched remotely. Upgrading to version 1.8 is able to address this issue. The patch is identified as 34d66b9f3231a0e2dc0e536a6fe615d736e863f7. It is recommended to upgrade the affected component. VDB-225350 is the identifier assigned to this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2012-10011?

It affects 1 product.


Products: Contus Hd Flv Player.

## How do I fix CVE-2012-10011?

No fix has been published for CVE-2012-10011 yet. Limit exposure of the affected software until one is available.

## Is CVE-2012-10011 being exploited?

There is no known exploitation of CVE-2012-10011 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-10011 and fix it if it is affected.

What it is: CVE-2012-10011 is a medium-severity SQL injection vulnerability in HD FLV PLayer Plugin, published on 9 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-10011 in the wild and no public exploit code.

Affected product: HD FLV PLayer Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-10011/ (Markdown: https://insights.sbomify.com/CVE-2012-10011/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-10011
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-10011
- OSV: https://osv.dev/vulnerability/CVE-2012-10011

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-10011/
Summaries are generated and may contain mistakes; the official description above is the record.
