{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-10013 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2012-10013 yet. Limit exposure of the affected software until one is available.","what":"CVE-2012-10013 is a low-severity cross-site scripting vulnerability in Kau-Boy Backend Localization Plugin, published on 24 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2012-10013 and fix it if it is affected.\n\nWhat it is: CVE-2012-10013 is a low-severity cross-site scripting vulnerability in Kau-Boy Backend Localization Plugin, published on 24 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2012-10013 in the wild and no public exploit code.\n\nAffected product: Kau-Boy Backend Localization Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-10013/ (Markdown: https://insights.sbomify.com/CVE-2012-10013/index.md)","id":"CVE-2012-10013","markdown":"https://insights.sbomify.com/CVE-2012-10013/index.md","name":"CVE-2012-10013","record":{"aliases":["GHSA-8m5p-37vm-f6cv"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via the Backend Localization Plugin, potentially compromising user sessions or site integrity.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"backend_localization","vendor":"kau-boys"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Kau-Boy Backend Localization Plugin up to 1.6.1 on WordPress. It has been rated as problematic. This issue affects some unknown processing of the file backend_localization.php. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.0 is able to address this issue. The patch is named 43dc96defd7944da12ff116476a6890acd7dd24b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-227231.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Kau-Boy Backend Localization Plugin backend_localization.php cross site scripting","id":"CVE-2012-10013","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2012"},"n_packages":0,"n_references":4,"next":{"headline":"Kau-Boy Backend Localization Plugin backend_localization.php localize_backend cross site scripting","id":"CVE-2012-10014"},"packages":[],"prev":{"headline":"BestWebSoft Facebook Like Button facebook-button-plugin.php fcbk_bttn_plgn_settings_page cross-site request forgery","id":"CVE-2012-10012"},"products":["Backend Localization Plugin"],"published":"2023-04-24","related":[{"cvss_score":4.3,"headline":"WordPress Backend Localization Plugin \u003c= 2.1.10 is vulnerable to Cross Site Request Forgery (CSRF)","id":"CVE-2023-44471","kev_date_added":null,"published":"2023-10-10"},{"cvss_score":3.5,"headline":"Kau-Boy Backend Localization Plugin backend_localization.php localize_backend cross site scripting","id":"CVE-2012-10014","kev_date_added":null,"published":"2023-04-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Kau-Boy"]},"summary":"Remote attackers can inject malicious scripts via the Backend Localization Plugin, potentially compromising user sessions or site integrity.","url":"https://insights.sbomify.com/CVE-2012-10013/"}