# CVE-2012-10014: Kau-Boy Backend Localization Plugin backend_localization.php localize_backend cross site scripting

> Remote attackers can inject malicious scripts via the backend localization settings, potentially compromising admin accounts.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 24 Apr 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-cgg5-8gwc-3f9x

## What is CVE-2012-10014?

CVE-2012-10014 is a low-severity cross-site scripting vulnerability in Kau-Boy Backend Localization Plugin, published on 24 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic has been found in Kau-Boy Backend Localization Plugin 2.0 on WordPress. Affected is the function backend_localization_admin_settings/backend_localization_save_setting/backend_localization_login_form/localize_backend of the file backend_localization.php. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 2.0.1 is able to address this issue. The name of the patch is 36f457ee16dd114e510fd91a3ea9fbb3c1f87184. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-227232.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2012-10014?

It affects 1 product.


Products: Kau-Boys Backend Localization.

## How do I fix CVE-2012-10014?

No fix has been published for CVE-2012-10014 yet. Limit exposure of the affected software until one is available.

## Is CVE-2012-10014 being exploited?

There is no known exploitation of CVE-2012-10014 in the wild and no public exploit code.

## Other vulnerabilities in Kau-Boy Backend Localization Plugin

- [CVE-2023-44471](https://insights.sbomify.com/CVE-2023-44471/): WordPress Backend Localization Plugin <= 2.1.10 is vulnerable to Cross Site Request Forgery (CSRF) (medium 4.3)
- [CVE-2012-10013](https://insights.sbomify.com/CVE-2012-10013/): Kau-Boy Backend Localization Plugin backend_localization.php cross site scripting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-10014 and fix it if it is affected.

What it is: CVE-2012-10014 is a low-severity cross-site scripting vulnerability in Kau-Boy Backend Localization Plugin, published on 24 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-10014 in the wild and no public exploit code.

Affected product: Kau-Boy Backend Localization Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-10014/ (Markdown: https://insights.sbomify.com/CVE-2012-10014/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-10014
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-10014
- OSV: https://osv.dev/vulnerability/CVE-2012-10014

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-10014/
Summaries are generated and may contain mistakes; the official description above is the record.
