# CVE-2012-10015: BestWebSoft Twitter Plugin Settings Page twitter.php twttr_settings_page cross-site request forgery


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 30 May 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-vjqm-g4gj-9mj4

## What is CVE-2012-10015?

CVE-2012-10015 is a medium-severity vulnerability in BestWebSoft Twitter Plugin, published on 30 May 2023. 

### Official description

A vulnerability was found in BestWebSoft Twitter Plugin up to 2.14 on WordPress. It has been classified as problematic. Affected is the function twttr_settings_page of the file twitter.php of the component Settings Page. The manipulation leads to cross-site request forgery. It is possible to launch the attack remotely. Upgrading to version 2.15 is able to address this issue. The patch is identified as a6d4659cbb2cbf18ccb0fb43549d5113d74e0146. It is recommended to upgrade the affected component. VDB-230154 is the identifier assigned to this vulnerability.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2012-10015?

It affects 1 product.


Products: Bestwebsoft Twitter.

## How do I fix CVE-2012-10015?

No fix has been published for CVE-2012-10015 yet. Limit exposure of the affected software until one is available.

## Is CVE-2012-10015 being exploited?

There is no known exploitation of CVE-2012-10015 in the wild and no public exploit code.

## Other vulnerabilities in BestWebSoft Twitter Plugin

- [CVE-2014-125103](https://insights.sbomify.com/CVE-2014-125103/): BestWebSoft Twitter Plugin twitter.php twttr_settings_page cross site scripting (low 2.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-10015 and fix it if it is affected.

What it is: CVE-2012-10015 is a medium-severity vulnerability in BestWebSoft Twitter Plugin, published on 30 May 2023. 
Exploitation: There is no known exploitation of CVE-2012-10015 in the wild and no public exploit code.

Affected product: BestWebSoft Twitter Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-10015/ (Markdown: https://insights.sbomify.com/CVE-2012-10015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-10015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-10015
- OSV: https://osv.dev/vulnerability/CVE-2012-10015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-10015/
Summaries are generated and may contain mistakes; the official description above is the record.
