# CVE-2012-10017: BestWebSoft Portfolio Plugin cross-site request forgery


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 26 Dec 2023
- **Updated:** 21 Nov 2024
- **Also known as:** GHSA-85qg-rq64-mxx7

## What is CVE-2012-10017?

CVE-2012-10017 is a medium-severity vulnerability in BestWebSoft Portfolio Plugin, published on 26 Dec 2023. 

### Official description

A vulnerability was found in BestWebSoft Portfolio Plugin up to 2.04 on WordPress. It has been classified as problematic. This affects an unknown part. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 2.06 is able to address this issue. The patch is named 68af950330c3202a706f0ae9bbb52ceaa17dda9d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-248955.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2012-10017?

It affects 1 product.


Products: Bestwebsoft Portfolio.

## How do I fix CVE-2012-10017?

No fix has been published for CVE-2012-10017 yet. Limit exposure of the affected software until one is available.

## Is CVE-2012-10017 being exploited?

There is no known exploitation of CVE-2012-10017 in the wild and no public exploit code.

## Other vulnerabilities in BestWebSoft Portfolio Plugin

- [CVE-2014-125109](https://insights.sbomify.com/CVE-2014-125109/): BestWebSoft Portfolio Plugin bws_menu.php bws_add_menu_render cross site scripting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-10017 and fix it if it is affected.

What it is: CVE-2012-10017 is a medium-severity vulnerability in BestWebSoft Portfolio Plugin, published on 26 Dec 2023. 
Exploitation: There is no known exploitation of CVE-2012-10017 in the wild and no public exploit code.

Affected product: BestWebSoft Portfolio Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-10017/ (Markdown: https://insights.sbomify.com/CVE-2012-10017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-10017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-10017
- OSV: https://osv.dev/vulnerability/CVE-2012-10017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-10017/
Summaries are generated and may contain mistakes; the official description above is the record.
