CVE-2012-1053 Puppet Privilege Escallation
Local attackers can escalate privileges in Puppet due to improper group privilege management in the SUIDManager, allowing unauthorized access to higher permissions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-1053?
CVE-2012-1053 is a medium-severity vulnerability in Puppet Puppet Enterprise, published on 29 May 2012. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
The change_user method in the SUIDManager (lib/puppet/util/suidmanager.rb) in Puppet 2.6.x before 2.6.14 and 2.7.x before 2.7.11, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x before 2.0.3 does not properly manage group privileges, which allows local users to gain privileges via vectors related to (1) the change_user not dropping supplementary groups in certain conditions, (2) changes to the eguid without associated changes to the egid, or (3) the addition of the real gid to supplementary groups.
Weakness: CWE-264
Which versions are affected by CVE-2012-1053?
4 open source packages ship an affected version, including puppet. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
puppet RubyGems | From 2.6 | 2.6.14 |
puppet RubyGems | From 2.6 | 2.6.14 |
puppet RubyGems | From 2.7 | 2.7.11 |
puppet RubyGems | From 2.7 | 2.7.11 |
Products include Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Puppet, Puppetlabs Puppet Enterprise Users.
How do I fix CVE-2012-1053?
Upgrade puppet to a fixed version for your release line: 2.6.14 or 2.7.11.
Is CVE-2012-1053 being exploited?
There is no known exploitation of CVE-2012-1053 in the wild and no public exploit code.
Other vulnerabilities in Puppet Puppet Enterprise
Sources
Also known as DEBIAN-CVE-2012-1053, GHSA-77hg-g8cc-5r37.